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Before you start 

You will need to have completed Exercise 1 in order to complete Exercise 5 in this workbook. 
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Exercise 5: Mapping and visualising 2011 Census data 

In this session you will map the Census dataset downloaded in the exercise 1 from InFuse 
using ArcGIS. 

5.1 Formatting data file 
Open up the file you created in Exercise 1, you should have a file named: 
Data_AGE_ECOACT_INDUST_SEX_UNIT.csv 
 
We need to modify this file slightly so ArcMap will understand it. The second row shows the 
full category titles, we could abbreviate these. For example: 
 

 In cell F1, delete F317 and insert Male_all 
 In cell G1, delete F321 and insert Male_agg_ind 
 In cell H1, delete F318 and insert Female_all 
 In cell I1, delete F322 and insert Female_agg_ind 

 
Now delete Row 2. Your file should now look like this: 
 
 

 
 
Save and close this file, we will be using it in a later exercise. 
 

5.2 Downloading boundary data 
 
1. Go to: http://census.ukdataservice.ac.uk/ and go to: 
2. Get census data > Boundary data > Easy download 
3. At this point you will be asked to login (if you have not registered with the UK Data 

Service, then ask the trainer for a username and password) 

4. Select Easy download 
5. By default you should be within the England tab, click the English Districts, UAs and 

London Boroughs 2011 link 
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6. Under English Districts, Unitary Authorities and London Boroughs 2011, Clipped and 

Generalised heading click ArcGIS SHAPE zip (2.2MB) 

 

7. This will start to download the boundary dataset.  Save the Zip file to your computer in 

the folder you created earlier – it will be named by default as 

England_lad_2011_gen_clipped.zip 

8. Navigate to the zip file and right click and select Extract all to unzip the files 

9. You also need to download the Welsh boundaries, so go back to EasyDowload, and this 

time click the Wales tab, click Welsh Unitary Authorities 2011,  and then click the ArcGIS 

SHAPE zip (625.kb) under the Welsh Unitary Authorities 2011, Clipped and 

Generalised heading. Save this file to the folder you created earlier. 

10. Go to the zip files you have created, and unzip both of these zip files (by right clicking and 

extract all) 

5.3 Matching data in ArcMap 
 

We can now map the census aggregate data we downloaded from InFuse and combine it 

with the census boundary data 

1. Open ArcMap (Start > All Programs > ArcGIS > ArcMap 10.  NB this may be different 

on your computer) 
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2. When prompted, choose ‘A new empty map’ and click OK.  This will open a new 

ArcMap session with no data loaded. 

If you are new to ArcMap, feel free to explore the interface to help you become familiar with 

the options available in the menus and toolbars. 

3. Click on the File menu and Select Add Data > Add Data 

4. Navigate to the folder containing the boundary data you downloaded from Easy 

Download earlier  

N.B. you may have to click the Connect to Folder button  to see your folder. 

5. Click to select England_lad_2011_gen_clipped.shp dataset and click Add (NB if the 

data isn’t listed, ensure you have unzipped the England_lad_2011_gen_clipped..zip 

file downloaded from Easy Download. You should now see a map of all of the Unitary 

Authorities/Local Authority Districts for England. 

6. Now repeat steps 3 to 5, to add the Welsh boundaries 

 

7. Repeat steps 3 to 5 above again, but this time select the data you downloaded from 

InFuse (i.e. Data_AGE_ECOACT_INDUST_SEX_UNIT.csv, within a folder beginning 

with numbers e.g. 2011419105212203_AGE_ECOACT_INDUST_SEX_UNIT) 

 

The data will be displayed in the main data view window and listed in the Table of Contents 

(TOC) on the left hand side.  ArcMap will assign a random single colour to the whole dataset.  

This is fine if we just want to see the Unitary Authorities and Districts but it will be more useful 

and interesting to display by one of the variables we downloaded from InFuse. 
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5.4 Visualising data in ArcMap 
 

1. Right-click England_lad_2011_gen_clipped on the left and select Joins and Relates 

> Join… 

2. Change the options in the screen as follows: 

 

3. Click OK 

4. Right click England_lad_2011_gen_clipped again and this time select open 

attribute table. This will show you that the aggregate and the boundary files have 

now been joined, and will indicate if there are any problems. Close this. 
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5. Right click England_lad_2011_gen_clipped again, but this time click Properties, and 

then the Symbology tab > select Quantities on the left and choose Graduated 

Colors. 

6. We are going to display the data by the number of people who work in the 

Agriculture, forestry and fishing industry, Select either Male_agg_ind  or 

Female_agg_ind.  

7. Select a suitable Color Ramp from the drop down menu. 

 

 

8. Click Apply then OK.  The data will now be coloured to show the number of males or 

females (depending on your selection) working in the Agriculture, forestry and fishing 

industry in England 

9. Repeat steps 1 to 8 but for the welsh data. You should end up wuth a map that looks 

like this: 
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Visualising the data by the total count of people working in an industry may not be entirely 

useful on its own because it does not take into account the population of each District / 

Unitary Authority.  In order to provide a more useful visualisation, we can display the data as a 

ratio of the people. We also downloaded the all categories for industry by sex– this is total 

amount all 16-74 year olds in employment in the week before the census. For both the 

English and Welsh data, do the following: 

 

10. Open up the Symbology options again (as in Step 5)  For the Normalization field 

select Female_all (or Male_all if you selected Male earlier).  

11. Click Apply and then OK.  The areas will now be visualised by a ratio of the number of 

Females working in the people working in the Agriculture, forestry and fishing 

industry to the total number of people in employment. 

12. Feel free to experiment with the classification options in the symbology tab to explore 

what the options do and how they change the display of the data. 

13.  In the main data view, use the  (information) tool to click and query individual 

areas to view attribute information. 

 

To create a map of your data: 

1. Go to View > Layout View.  In the Layout View there are various options for setting 

up a map layout to print or save. 

2. Go to File > Page and Print Setup to change paper size and orientation. 

3. Go to Insert to add various elements including North Arrow, Title, Legend and Scale. 

4. To save your map: Go to File > Export Map > Select desired file type  
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Exercise 6: Using Casweb to download and visualise 2001 Census 
aggregate data 

6.1 Downloading 2001 Aggregate Census data from Casweb 

Casweb is our older interface, and contains 1971 to 2001 census aggregate data. Casweb 
works a little differently for each census, this exercise demonstrates how to download  and 
map data from the 2001 Census. Casweb has the advantage of having aggregate and 
boundary data bundled together for the 1991 and 2001 Censuses. In the future we hope to 
have this functionality in InFuse 

From the Census Support homepage (census.ukdataservice.ac.uk) 

 Click Get census data 

 Click Aggregate data 

 Click Casweb 

 Click the Start Casweb 

Once you've logged into Casweb follow the link to 2001 Aggregate Statistics Datasets. 

You are now in a 3-step process: Define study area, Select Data and Output Data and we will 
take each step one at a time.  

 

Figure 1: Casweb - Select Data 
 



 

ukdataservice.ac.uk 9 

20 March 2014 

6.1.1 Define Study Area 

Follow these steps to define your study area:  

1. First you need to select the country containing your study area. The area we want to 
extract data for is London, so you should select England and then click Select lower 
geographies.  

2. Now you need to define the region of interest, which in this case is London. Select 
London  

3. We have no need to define the study area at lower zones because we wish to extract data 
for all CAS wards within London. So click Select output level

 

Figure 2: Select output level 

4. As we are interested in CAS wards, click the CAS Ward radio button in B Select 
Output geography and then press the Select data... button.  

 

Figure 3: Select output level 

To recap, you have started at the highest geographical level, worked your way down by 
refining your area as the Government Office Region of London, and chosen to output data for 
all CAS wards in London. Now let's choose some data!  

6.1.2 Select Data 

Census data are held in tables, within datasets which are listed. By default, the Key Statistics 
dataset (the first in the list) is selected. Not all datasets are available at all geographical levels. 
If a dataset is not available it will be greyed out.  

We will now choose a dataset 
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1. Click the Census Area Statistics Univariate Tables radio button 
2. Click the Select Dataset button.  

We will be selecting data from two tables  
 Table UV008 – ‘Country of Birth’ 

 Table UV009 – ‘Ethnic Group’, 

We can either select these straight from the scrollable list box of Tables or we can search for 
it. We are trying to find some variables concerning White ethnic groups and those with UK as 
their country of birth. 

3. Click UV008 Country of Birth 
4. Click Display Table Layout 

 

 

 

The following table layout should be displayed: 
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We are going to download 2 variables from this table: 

5. Tick the All People and the United Kingdom checkboxes 
6. Click Add variables to data selection 
7. Notice how the variables you selected now appear in the right hand box, they are 

listed as codes, for example UV0080003. Note that the first characters refer to the 
table ID and the last digits refer to the cell ID you ticked. When you download the 
data this will be the unique ID attached to it (ie it’s not going to be labelled “Country 
of Birth: UK,” it will be labelled “UV0080003”). You can click Rename to give it a more 
meaningful name, or you can refer back to the table in Casweb to find out what it 
means 

We now need to add data from another table, we can go back to the table selector by clicking 
on the                                   link. 

8. Click table UV009 Ethnic Group and click the Display Table Layout button. 
9. Once the table layout for UV009 has loaded we will be adding the ‘All People’ variable 

(UV0090001) and the variable for ‘White’ ethnic group (UV0090002) 
10. Now that we've selected the variables, you can now download the data. Click the Get 

Data button as shown below:  
 

1 Click 
here to 
select the 
variables 

2 Click here to 
add the variables 
to the Variable 
List 

3 Click here to 
select another 
table 
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Casweb will now process your request. 

6.1.3 Step 3 - Output Data 

You are now in the final stage of data extraction.  

Complete these remaining steps:  

7 The data downloads option page will now appear. You can type a name into the 
filename box, let’s enter example1 

8 You can choose to have the output as plain text or digital boundary data.  Choose 
Digital Boundary Data 

9 Ensure ESRI Shape is selected as the Format and click Execute Query 
 

 
 

10 Now save the file, you will use this file in the next exercise   

1 Select 
these 2 
variables 

3 Click this box to 
move to the next 
stage 

2 Click here to 
add the variables 
to the Variable 
List 
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6.2 Mapping and visualising census data 

 

In this session you will map the Census dataset downloaded in the previous exercise from 

Casweb using ArcGIS. 

1. Open ArcMap (Start > All Programs > ArcGIS >ArcMap.  NB this may be different on 

your computer) 

2. When prompted, choose ‘A new empty map’ and click OK.  This will open a new 

ArcMap session with no data loaded. 

If you are new to ArcMap, feel free to explore the interface to help you become familiar with 

the options available in the menus and toolbars. 

3. Click on the File menu and Select Add Data. 

4. Navigate to the folder containing your data downloaded from Casweb. N.B. you may 

have to click the Connect to Folder button  to see your folder. 

5. Click to select example1.shp dataset and click Add (NB if the data isn’t listed, ensure 

you have unzipped the example1.zip file downloaded from Casweb) 

 

The data will be displayed in the main data view window and listed in the Table of 

Contents (TOC) on the left hand side.  ArcMap will assign a random single colour to the 

whole dataset.  This is fine if we just want to see the CAS Wards but it will be more useful 

and interesting to display by one of the CAS variables contained in our dataset. 

6. Right-click example1.shp in the TOC on the left and select Properties. 

7. Click the Symbology tab > select Quantities on the left and choose Graduated 

Colors. 

8. We are going to display the data by the number of people born in the UK from the 

Country of Birth statistics.  In the Value field select UV0080003 (you may have 

renamed the field so might be different, we want the Country of Birth stats Born in UK 

value) 

9. Select a suitable Color Ramp from the drop down menu. 

10.  Click Apply then OK.  The data will now be coloured to show the distribution of 

those people born in the UK across the London CAS Wards. 

 

Visualising the data by the total count of people born in the UK only, may not be entirely 

useful on its own because it does not take into account the population of each ward.  In order 

to provide a more useful visualisation, we can display the data as a ratio of the people born in 

the UK to the total number of people per ward. 



 

ukdataservice.ac.uk 14 

20 March 2014 

 

11.  Open up the Symbology options again (as in Step 7)  For the Normalization field 

select UV0080001 – the total number of people from the Country of Birth table 

(again, you may have renamed this field)  

12.  Click Apply and then OK.  The CAS Wards will now be visualised by a ratio of the 

number of people born in the UK to the total number of people. 

13.  Feel free to experiment with the classification options in the symbology tab to 

explore what the options do and how they change the display of the data. 

14.  In the main data view, use the  (information) tool to click and query individual 

CAS Wards to view attribute information. 

To create a map of your data: 

5. Go to View > Layout View.  In the Layout View there are various options for setting 

up a map layout to print or save. 

6. Go to File > Page and Print Setup to change paper size and orientation. 

7. Go to Insert to add various elements including North Arrow, Title, Legend and Scale. 

8. To save your map: Go to File > Export Map > Select desired file type  

9. To print your map: Go to File > Print. 

 

 
 
 

Useful links 

 UK Data Service – Census Support: http://census.ukdataservice.ac.uk 

 Get data page: http://census.ukdataservice.ac.uk/get-data 

 Use data page: http://census.ukdataservice.ac.uk/use-data 

 InFuse: http://infuse.mimas.ac.uk 

 Casweb: http://casweb.mimas.ac.uk 

 Boundary data:	http://census.ukdataservice.ac.uk/get-data/boundary-data 

 2011 Census aggregate plans / data availability: 

http://census.ukdataservice.ac.uk/get-data/aggregate-data/2011-plans 

 Census forms:  

http://census.ukdataservice.ac.uk/use-data/censuses/forms 

 Census definitions:  

http://census.ukdataservice.ac.uk/use-data/censuses/definitions 


